Pages

Thursday, October 25, 2018

Elastix Problem


*** Local extension call problem **

goto Extentions from web panel and give sip alias

sip_alias = 135

If not ok then,,

 vi /etc/asterisk/extensions_custom.conf

exten => _XXXX,n,Goto(ext-local,${EXTEN},1)

rasterisk -x'dialplan reload'


*** freepbx page blan from web panel of elastix

 yum reinstall freePBX

** IF addons not working through web panel and have to install call center then

 yum search elastix-callcenter
yum install elastix-callcenter.noarch
 /etc/init.d/elastixdialer status
/etc/init.d/elastixdialer start
chkconfig elastixdialer on


** Elastix 4  Call-Center manual Installation : http://elastix.adaptixnetworks.com/4/extras/x86_64/RPMS/elastix-callcenter-2.2.0-17.noarch.rpm


or

http://elastix.adaptixnetworks.com/index.php?search=call&dir=4%2F&searchMode=f



/etc/init.d/elastixdialer start
chkconfig elastixdialer on

****************
----------------------------------------
Elastix admin user password reset
----------------------------------------
/usr/bin/sqlite3 /var/www/db/acl.db "UPDATE acl_user SET md5_password = '`echo -n newpassword|md5sum|cut -d ' ' -f 1`' WHERE name = 'admin'"

----------------------------------------------------

Wednesday, July 18, 2018

Dude Monitoring server installation, backup and restore




* DUDE Installation: 
---------------------------
* First adjust Router OS version with Dude-Server version
* for example, if RouterOS version 6.40.8 and download Dude-server with 6.40.8 version
from
https://mikrotik.com/download

also check router specifications like ... ( mipsle, mipsbe, ppc, x86, mmips, arm )

* Put packages to files and reboot

* /dude set enabled=(yes/no)

* /dude print
         enabled: yes
         data-directory: dude
          status: running

* by default all The Dude data is stored on system disk, if you wish to change it's location the use this command:

* /dude set data-directory=(new_db_path)

* dwonlaod dude client for windows to access/monitor/manage from windows


* connect dude server from windows dude client and configure as your requirement

** Backup 


/dude export-db  backup-file=dude-backup-18-7-2018

** Restore


/dude import-db  backup-file=dude-backup-18-7-2018



Thursday, July 12, 2018

MikroTik Multiple Gateway redundancy failover by Netwatch and firewall




MikroTik Multiple Gateway redundancy by Netwatch and firewall

* Exampe two WAN Internet
ether1 = wan1 = GW IP 192.168.10.1
ether2 = wan2 = GW IP 172.16.1.1\

* First make sure source gw ip not reachable via another interface ...

/ip firewall filter add chain output dst-address = 192.168.10.1 out-interface=ether1 action=accept
/ip firewall filter add chain output dst-address = 192.168.10.1  action=drop


/ip firewall filter add chain output dst-address = 172.16.1.1 out-interface=ether2 action=accept
/ip firewall filter add chain output dst-address = 172.16.1.1  action=drop


** Then create rules for ip -> route with gateway priority

** Then create netwatch to check evry 5 seconds
/tool netwatch host=192.168.10.1 interval 00:00:05 UP=/ip route enable 0 Down= /ip route disable 0
/tool netwatch host=172.6.1.1 interval 00:00:05 UP=/ip route enable 1 Down= /ip route disable 1



Saturday, June 30, 2018

BDCOM OLT Password Reset and New Fresh Configuration



BDCOM OLT Console Password Reset

Press "CTRL + P" when boot
it will enter
monitor#

and then type bellow command

monitor# delete startup-config

type "Y" and enter

AND finally reboot OLT/Switch

monitor# reboot

it will enter

switch>
switch> enable
switch#
switch# config
switch_confi#
switch_config# interface range gigabitEthernet 0/1 - 6
switch_cofnig_if_range#
switch_config_if_range# no shutdown
switch_config_if_range# exit
switch_config# interface range ePON 0/1 - 4
switch_config_if_range# no shutdown
switch_config_if_range# exit
switch_config#
switch_config# hostname New-OLT-Tayab-Khan
New-OLT-Tayab-Khan#
New-OLT-Tayab-Khan# write
New-OLT-Tayab-Khan# wirte all
New-OLT-Tayab-Khan_config#
New-OLT-Tayab-Khan_config# interface vlan 1
New-OLT-Tayab-Khan_config_vlan#
New-OLT-Tayab-Khan_config_vlan# ip address 172.16.10.1 255.255.255.252
New-OLT-Tayab-Khan_config_vlan#  no shutdown
New-OLT-Tayab-Khan_config_vlan# exit
New-OLT-Tayab-Khan_config#
New-OLT-Tayab-Khan_config# ip default-gateway 172.16.10.2
New-OLT-Tayab-Khan_config# write all
New-OLT-Tayab-Khan_config#
New-OLT-Tayab-Khan_config# ip http server
New-OLT-Tayab-Khan_config# write all

New-OLT-Tayab-Khan_config# aaa authentication login default local
New-OLT-Tayab-Khan_config# aaa authentication enable default none
New-OLT-Tayab-Khan_config# username admin password 0 admin
New-OLT-Tayab-Khan_config# ip sshd enable
New-OLT-Tayab-Khan_config# write all


      

Sunday, March 25, 2018

Juniper LACP and MikoTik Bonding



Juniper LACP (Aggregation / Ether Channel)
---------------------------------------------
** We want to use two port ge3 and ge3 for Juniper LACP

set chassis aggregated-devices ethernet device-count 3

set interfaces ge-0/0/3 ether-options 802.3ad ae1
set interfaces ge-0/0/4 ether-options 802.3ad ae1

set interfaces ae1 description AE-Interface-Tayab
set interfaces ae1 aggregated-ether-options lacp active periodic fast
set interfaces ae1 unit 0 family ethernet-switching interface-mode trunk
set interfaces ae1 unit 0 family ethernet-switching vlan members all


MikroTik Bonding
------------------------
Goto Interface and click Bonding

Goto Tab "Bonding" use Slave Ports and use mode 802.3ad






Thursday, March 1, 2018

Juniper Policy Based Routing ( Upload traffic PBR)



* Create a routing Instance "upstream1" and set gateway
set routing-instances upstream1 instance-type forwarding
set routing-instances upstream1 routing-options static route 0.0.0.0/0 qualified-next-hop 10.10.10.1(Upstream1-Gateway)

* Create PBR name "uplink-pbr" and Allow source IP addresses for pbr

set firewall family inet filter uplink-pbr term 30 from source-address 192.168.100.0/24
set firewall family inet filter uplink-pbr term 30 then routing-instance upstream1
set firewall family inet filter uplink-pbr term default then accept


set routing-options rib-groups pbr-group import-rib inet.0
set routing-options rib-groups pbr-group import-rib upstream1.inet.0
set routing-options interface-routes rib-group inet pbr-group


* Apply "uplink-pbr" to Client Gateway Inernface
set interfaces ge-1/0/6 unit 0 description *****Client-01****
set interfaces ge-1/0/6 unit 0 family inet filter input uplink-pbr